Supported Android Versions

API Level 21+ – Version 5.0 – Lollipop

* We recommend upgrading to the latest Android OS available in order to ensure the latest stability and security levels.

Recommended Devices

Minimum 4GB of RAM recommended.

Phones

Pixel 2 / Pixel 2 XL

Pixel 3 / Pixel 3 XL 

Huawei Mate 20 Pro

Huawei P20 Pro

OnePlus 6T

Samsung Galaxy S8

Samsung Galaxy S9

Samsung Galaxy Note 9

Tablets

DJI CrystalSky 5.5″ High Brightness 

DJI CrystalSky 7.85″ High Brightness 

DJI CrystalSky 7.85″ Ultra Brightness 

Samsung Galaxy Tab S3

Samsung Galaxy Tab S4

Huawei MediaPad M3 

Huawei MediaPad M5 

♠ Samsung’s customization’s on top of the Android Operating System can sometimes cause unexpected behavior

♣ This device may have issues with wifi network connectivity. Have experienced these in the past on the M3. Unknown if the M5 has the same issues.

∇ CrystalSky device specs are unknown and may be outdated. These devices run a DJI customized version of the Android OS. Therefore they are slower to get updates and the version they run is older than most flagship devices. CrystalSky devices may experience issues in connectivity and GPS.

Supported Screen Sizes

A screen size bigger than 4.7″ is recommended. Smaller screens aren’t recommended.

Recommendations

  • Always keep up to date with the latest Kittyhawk app version.
  • Verify that you have at least 1 GB of free storage space.
  • Close down all running Apps in background to improve performance.